summaryrefslogtreecommitdiffstats
path: root/recipes-qt/b2qt-addons/b2qt-demos.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/b2qt-addons/b2qt-demos.bb')
-rw-r--r--recipes-qt/b2qt-addons/b2qt-demos.bb56
1 files changed, 32 insertions, 24 deletions
diff --git a/recipes-qt/b2qt-addons/b2qt-demos.bb b/recipes-qt/b2qt-addons/b2qt-demos.bb
index c8423e1..eec5bc4 100644
--- a/recipes-qt/b2qt-addons/b2qt-demos.bb
+++ b/recipes-qt/b2qt-addons/b2qt-demos.bb
@@ -1,27 +1,35 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
21 29
22DESCRIPTION = "Boot to Qt Demos" 30DESCRIPTION = "Boot to Qt Demos"
23LICENSE = "QtEnterprise" 31LICENSE = "BSD | The-Qt-Company-DCLA-2.1"
24LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=1bf19846314f7b0fa81dc4db92338713;beginline=1;endline=40" 32LIC_FILES_CHKSUM = "file://about-b2qt/AboutBoot2Qt.qml;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49"
25 33
26inherit qmake5 34inherit qmake5
27 35
@@ -34,15 +42,15 @@ SRC_URI = " \
34 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \ 42 https://s3-eu-west-1.amazonaws.com/qt-files/examples/Videos/Qt+World+Summit+2015+Recap.mp4;name=video2 \
35 " 43 "
36 44
37PV = "5.6+git${SRCPV}" 45PV = "5.7+git${SRCPV}"
38 46
39BRANCH = "5.6" 47BRANCH = "5.7"
40BROWSER_BRANCH = "dev" 48BROWSER_BRANCH = "dev"
41QT_BRANCH = "5.6" 49QT_BRANCH = "5.7"
42SRCREV_demos = "2dcc014980437b87564b7f9f86a06894efa5ea75" 50SRCREV_demos = "cd9f0c40f30226c7ce1c3259aea8ebca08acfbb8"
43SRCREV_qtcanvas3d = "5a17c4ca0552c9f4e6b5646f0cee2b21a55c3d18" 51SRCREV_qtcanvas3d = "32404e27101c5ec81b4ab965faf38263429bbc5a"
44SRCREV_qtquickcontrols = "fc9c57cf8b66bafbcaa6957bb22293047aa3d9df" 52SRCREV_qtquickcontrols = "c6713e212ef0b97c45d6466b73220567e94a05f1"
45SRCREV_qtwebbrowser = "c86bb8a400f79be205025598310926df5d01c7bc" 53SRCREV_qtwebbrowser = "7c570ee4297946f3ed70565a630d690070533cbd"
46SRCREV_FORMAT = "demos_qtcanvas3d_qtquickcontrols_qtwebbrowser" 54SRCREV_FORMAT = "demos_qtcanvas3d_qtquickcontrols_qtwebbrowser"
47 55
48SRC_URI[video1.md5sum] = "56de4dcfd5201952dce9af9c69fcec9b" 56SRC_URI[video1.md5sum] = "56de4dcfd5201952dce9af9c69fcec9b"
@@ -87,18 +95,18 @@ do_install_append() {
87 sed -i 's/qrc:\(\/\)\?//g' ${D}/data/user/qt/canvas3d-planets/*.qml 95 sed -i 's/qrc:\(\/\)\?//g' ${D}/data/user/qt/canvas3d-planets/*.qml
88 sed -i 's/qrc:\(\/\)\?//g' ${D}/data/user/qt/canvas3d-planets/*.js 96 sed -i 's/qrc:\(\/\)\?//g' ${D}/data/user/qt/canvas3d-planets/*.js
89 sed -i 's/StyledSlider/Slider/g' ${D}/data/user/qt/canvas3d-planets/planets.qml 97 sed -i 's/StyledSlider/Slider/g' ${D}/data/user/qt/canvas3d-planets/planets.qml
90 sed -i '39 i import QtQuick.Controls 1.2' ${D}/data/user/qt/canvas3d-planets/planets.qml 98 sed -i '/import QtCanvas3D/a import QtQuick.Controls 1.2' ${D}/data/user/qt/canvas3d-planets/planets.qml
91 99
92 # Qt Quick Extras 100 # Qt Quick Extras
93 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/dashboard/qml ${D}/data/user/qt/enterprise-dashboard/ 101 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/dashboard/qml ${D}/data/user/qt/enterprise-dashboard/
94 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/dashboard/images ${D}/data/user/qt/enterprise-dashboard/ 102 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/dashboard/images ${D}/data/user/qt/enterprise-dashboard/
95 103
96 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/gallery/qml ${D}/data/user/qt/enterprise-gallery/ 104 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/gallery/qml ${D}/data/user/qt/enterprise-gallery/
97 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/gallery/images ${D}/data/user/qt/enterprise-gallery/ 105 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/gallery/images ${D}/data/user/qt/enterprise-gallery/
98 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/gallery/fonts ${D}/data/user/qt/enterprise-gallery/ 106 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/gallery/fonts ${D}/data/user/qt/enterprise-gallery/
99 107
100 cp -r ${WORKDIR}/qtquickcontrols/examples/quick/extras/flat/images ${D}/data/user/qt/enterprise-flat-controls/ 108 cp -r ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/flat/images ${D}/data/user/qt/enterprise-flat-controls/
101 cp ${WORKDIR}/qtquickcontrols/examples/quick/extras/flat/*.qml ${D}/data/user/qt/enterprise-flat-controls/ 109 cp ${WORKDIR}/qtquickcontrols/examples/quickcontrols/extras/flat/*.qml ${D}/data/user/qt/enterprise-flat-controls/
102 110
103 sed -i '/import QtQuick.Window/c\' ${D}/data/user/qt/enterprise-dashboard/qml/dashboard.qml ${D}/data/user/qt/enterprise-gallery/qml/gallery.qml 111 sed -i '/import QtQuick.Window/c\' ${D}/data/user/qt/enterprise-dashboard/qml/dashboard.qml ${D}/data/user/qt/enterprise-gallery/qml/gallery.qml
104 sed -i 's/Window /Rectangle /1' ${D}/data/user/qt/enterprise-dashboard/qml/dashboard.qml ${D}/data/user/qt/enterprise-gallery/qml/gallery.qml 112 sed -i 's/Window /Rectangle /1' ${D}/data/user/qt/enterprise-dashboard/qml/dashboard.qml ${D}/data/user/qt/enterprise-gallery/qml/gallery.qml