summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive')
-rw-r--r--recipes-qt/automotive/qtivi_git.bb40
1 files changed, 35 insertions, 5 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 103933f..3dbf07e 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -35,18 +35,48 @@ LIC_FILES_CHKSUM = "file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ 35 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02" 36 file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02"
37 37
38DEPENDS = "qtbase qtdeclarative qtmultimedia" 38DEPENDS = "qtbase qtdeclarative qtmultimedia qtivi-native"
39 39DEPENDS_class-native = "qtbase"
40SRCREV = "40e8ba1c8dd89474c4d890a3e050890d0cd9654e" 40DEPENDS_class-nativesdk = "qtbase"
41 41
42inherit qt5-module 42inherit qt5-module
43inherit python3native
43require recipes-qt/qt5/qt5-git.inc 44require recipes-qt/qt5/qt5-git.inc
44 45
45PACKAGECONFIG ?= "taglib dlt" 46QT_MODULE_BRANCH_QFACE = "upstream/develop"
47
48SRC_URI += " \
49 ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \
50"
51
52SRCREV_qtivi = "3205b6e8f57273096ae60d8f6fcdbe597c350393"
53SRCREV_qface = "b1d96d85a7c43ac74335b9a1a99a68507047f5bc"
54SRCREV = "${SRCREV_qtivi}"
55SRCREV_FORMAT = "qtivi_qface"
56
57PACKAGECONFIG ?= "taglib dlt ivigenerator"
46PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib" 58PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
47PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon" 59PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
48PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only" 60PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
61# For cross-compiling tell qtivi to use the system-ivigenerator, which is installed by the native recipe"
62PACKAGECONFIG[ivigenerator] = "QMAKE_EXTRA_ARGS+=-system-ivigenerator"
63PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python3 python3-virtualenv"
64PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
65
66PACKAGECONFIG_class-native ??= "host-tools-only ivigenerator-native"
67PACKAGECONFIG_class-nativesdk ??= "${PACKAGECONFIG_class-native}"
68
69EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}"
49 70
50EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" 71do_compile_prepend() {
72 # Otherwise pip might cache or reuse something from our home folder
73 export HOME="${STAGING_DATADIR_NATIVE}"
74 # This is needed as otherwise the virtualenv tries to use the libs from the host
75 export LD_LIBRARY_PATH="${STAGING_LIBDIR_NATIVE}"
76 # Let qtivi use the python3-native binaries
77 export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native"
78}
51 79
80BBCLASSEXTEND += "native nativesdk"
52 81
82INSANE_SKIP_${PN}_class-native = "already-stripped"