summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtwebbrowser_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/qtwebbrowser_git.bb')
-rw-r--r--recipes-qt/automotive/qtwebbrowser_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
new file mode 100644
index 0000000..b06446e
--- /dev/null
+++ b/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -0,0 +1,45 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Web Browser"
31LICENSE = "GPL-3.0"
32LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=a40e2bb02b1ac431f461afd03ff9d1d6"
33
34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
36
37QT_MODULE = "qt-apps-qtwebbrowser"
38QT_MODULE_BRANCH = "dev"
39
40SRCREV = "023733af5523a5ad84359926224fa106001215f4"
41
42DEPENDS = "qtbase qtdeclarative qtwebengine"
43
44FILES_${PN} += "/data/user/qt/qtwebbrowser-app"
45FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser-app/.debug"