summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtivi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/qtivi_git.bb')
-rw-r--r--recipes-qt/automotive/qtivi_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtivi_git.bb b/recipes-qt/automotive/qtivi_git.bb
index 40cfbf1..b5536a4 100644
--- a/recipes-qt/automotive/qtivi_git.bb
+++ b/recipes-qt/automotive/qtivi_git.bb
@@ -89,6 +89,19 @@ do_install_prepend() {
89 set_python_paths 89 set_python_paths
90} 90}
91 91
92# This needs a modified python3 recipe which copies the binary into a path where this recipe can pick it up
93# This is needed to provide a proper executable using the correct interpreter in the SDK.
94# See https://bugreports.qt.io/browse/AUTOSUITE-176
95do_install_append_class-nativesdk() {
96 export IVIGENERATOR_ENABLED="${@bb.utils.contains("PACKAGECONFIG", "ivigenerator-native", "1", "0", d)}"
97
98 if [ "${IVIGENERATOR_ENABLED}" = "1" ]; then
99 cp ${STAGING_BINDIR}/qt5/python3* ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/
100 rm -f ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
101 ln -sf python3 ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
102 fi
103}
104
92 105
93BBCLASSEXTEND += "native nativesdk" 106BBCLASSEXTEND += "native nativesdk"
94 107