summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtapplicationmanager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
index 3b54890..c4f1eb4 100644
--- a/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -29,16 +29,18 @@
29 29
30DESCRIPTION = "Qt component for application lifecycle management" 30DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=43a31c6abffdd61c938811959b3c1b71"
33 33
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37SRCREV = "be9e9a37c2cd848cfdbb97990e0047f1a0834a8a" 37SRCREV = "74d8bb0c8590dec7d6106781b1aa460756425d8f"
38 38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" 40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
41
41RDEPENDS_${PN} = "libcrypto ${PN}-tools" 42RDEPENDS_${PN} = "libcrypto ${PN}-tools"
43RDEPENDS_${PN}_remove_mingw32 = "libcrypto"
42 44
43EXTRA_QMAKEVARS_PRE += "\ 45EXTRA_QMAKEVARS_PRE += "\
44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \ 46 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
@@ -55,3 +57,12 @@ do_install_append() {
55FILES_${PN} += "\ 57FILES_${PN} += "\
56 /opt/am \ 58 /opt/am \
57 " 59 "
60
61BBCLASSEXTEND += "nativesdk"
62
63DEPENDS_class-nativesdk = "qtbase nativesdk-glibc-locale"
64DEPENDS_class-nativesdk_remove_mingw32 += "nativesdk-glibc-locale"
65
66EXTRA_QMAKEVARS_PRE_class-nativesdk += "\
67 -config tools-only \
68 "