summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qtapplicationmanager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/qtapplicationmanager_git.bb')
-rw-r--r--recipes-qt/automotive/qtapplicationmanager_git.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qtapplicationmanager_git.bb b/recipes-qt/automotive/qtapplicationmanager_git.bb
new file mode 100644
index 0000000..028df78
--- /dev/null
+++ b/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -0,0 +1,62 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=317fda864ac33d41406ff3938c3e78d1"
33
34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
36
37SRCREV = "8a4b17fade4507860919fbbf9ea42f813a26be76"
38
39DEPENDS = "qtbase qtdeclarative libyaml libarchive \
40 ${@base_contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}"
41RDEPENDS_${PN} = "libcrypto"
42
43EXTRA_QMAKEVARS_PRE += "\
44 ${@base_contains("DISTRO_FEATURES", "wayland", "-config force-multiprocess", "-config force-singleprocess", d)} \
45 -config enable-dummydata \
46 -config enable-ivi-logging \
47 -config install-prefix=/usr \
48 -config systemd-workaround \
49 -config hardware-id=neptune \
50 "
51
52do_install_append() {
53 install -m 0755 -d ${D}/opt/am/
54 install -m 0644 ${S}/template-opt/am/config.yaml ${D}/opt/am/
55}
56
57FILES_${PN} += "\
58 /opt/am \
59 ${libdir}/appman \
60 ${datadir}/dbus-1"
61FILES_${PN}-dbg += "${libdir}/appman/.debug"
62FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/*.prl"