summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/qmllive-target_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/qmllive-target_git.bb')
-rw-r--r--recipes-qt/automotive/qmllive-target_git.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-qt/automotive/qmllive-target_git.bb b/recipes-qt/automotive/qmllive-target_git.bb
new file mode 100644
index 0000000..7819941
--- /dev/null
+++ b/recipes-qt/automotive/qmllive-target_git.bb
@@ -0,0 +1,49 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QML Live target runtime"
31
32LICENSE = "GPL-3.0"
33LIC_FILES_CHKSUM = "file://../../LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
34
35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc
37
38QT_MODULE = "qt-apps-qmllive"
39QT_MODULE_BRANCH = "master"
40
41SRC_URI += " \
42 file://qmllive-target.patch \
43 "
44
45SRCREV = "d0d41c71c4691a5f3e2b72e22917f314b4190ffc"
46
47S = "${WORKDIR}/git/src/runtime"
48
49DEPENDS = "qtbase qtdeclarative"