summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/neptune-ui_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/neptune-ui_git.bb')
-rw-r--r--recipes-qt/automotive/neptune-ui_git.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-qt/automotive/neptune-ui_git.bb b/recipes-qt/automotive/neptune-ui_git.bb
new file mode 100644
index 0000000..66703c6
--- /dev/null
+++ b/recipes-qt/automotive/neptune-ui_git.bb
@@ -0,0 +1,71 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Neptune IVI UI"
31LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=bc0cb4bfd3f72b3fe47b2b2d0d89762c"
33
34inherit qt5-module systemd
35require recipes-qt/qt5/qt5-git.inc
36
37QT_MODULE = "qt-apps-neptune-ui"
38QT_MODULE_BRANCH = "master"
39
40SRC_URI += " \
41 file://neptune.service \
42 "
43
44SRCREV = "3d36a7b8e53770c91db60cec9586ef572a2f2814"
45
46DEPENDS = "qtbase qtdeclarative"
47RDEPENDS_${PN} = "qtapplicationmanager qtivi qtvirtualkeyboard \
48 ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
49
50do_configure_prepend() {
51 echo "qml.path = /opt/neptune" >> ${S}/neptuneui.pro
52}
53
54do_install_append() {
55 install -m 0755 -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/neptune.service ${D}${systemd_unitdir}/system/
57
58 install -m 0644 ${S}/Main*.qml ${D}/opt/neptune
59 install -m 0644 ${S}/MainWithCluster.qml ${D}/opt/neptune
60 install -m 0644 ${S}/am-config.yaml ${D}/opt/neptune
61}
62
63PACKAGES =+ "${PN}-apps"
64RRECOMMENDS_${PN} += "${PN}-apps"
65
66FILES_${PN}-apps += "/opt/neptune/apps"
67FILES_${PN} += "\
68 /opt/neptune \
69 "
70
71SYSTEMD_SERVICE_${PN} = "neptune.service"