summaryrefslogtreecommitdiffstats
path: root/recipes-qt/automotive/gammaray_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/automotive/gammaray_git.bb')
-rw-r--r--recipes-qt/automotive/gammaray_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/automotive/gammaray_git.bb b/recipes-qt/automotive/gammaray_git.bb
new file mode 100644
index 0000000..0456023
--- /dev/null
+++ b/recipes-qt/automotive/gammaray_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "GammaRay Qt introspection probe"
2HOMEPAGE = "http://www.kdab.com/gammaray"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.GPL.txt;md5=5996517d53e3c2722d457fb633e970ed"
6
7inherit cmake_qt5
8
9SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
10
11BRANCH = "master"
12SRCREV = "6262eaeaee74109f9c1bd85de99c9b039d8938f5"
13PV = "master+git${SRCPV}"
14
15DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OECMAKE += " -DGAMMARAY_BUILD_UI=OFF -DGAMMARAY_CORE_ONLY_LAUNCHER=ON"
20
21FILES_${PN}-dev += " \
22 /usr/lib/cmake/* \
23 /usr/mkspecs/modules/* \
24"
25FILES_${PN}-dbg += " \
26 /usr/lib/.debug/* \
27 /usr/lib/gammaray/*/*/.debug \
28 /usr/lib/gammaray/*/*/styles/.debug \
29"