summaryrefslogtreecommitdiffstats
path: root/meta-vib4-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-vib4-extras')
-rw-r--r--meta-vib4-extras/conf/layer.conf32
-rw-r--r--meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend15
-rw-r--r--meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend7
-rw-r--r--meta-vib4-extras/recipes/linux/linux-nvidia.bbappend57
-rw-r--r--meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch18
-rw-r--r--meta-vib4-extras/recipes/systemd/systemd_%.bbappend22
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend41
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc12
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc10
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc11
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc12
11 files changed, 237 insertions, 0 deletions
diff --git a/meta-vib4-extras/conf/layer.conf b/meta-vib4-extras/conf/layer.conf
new file mode 100644
index 0000000..89fb47e
--- /dev/null
+++ b/meta-vib4-extras/conf/layer.conf
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28"
29
30BBFILE_COLLECTIONS += "b2qt_vib4"
31BBFILE_PATTERN_b2qt_vib4 := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_vib4 = "20"
diff --git a/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend b/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend
new file mode 100644
index 0000000..d7353bc
--- /dev/null
+++ b/meta-vib4-extras/recipes/glibc/glibc_2.22.bbappend
@@ -0,0 +1,15 @@
1# Append --enable-kernel flag to configure flags
2# only for target build case.
3# We are setting this to kernel 3.18 to keep glibc
4# compatbile across all 3.18 series
5# We will not support < 3.18 for V4L:
6EXTRA_OECONF_append_class-target = " \
7 --enable-kernel=3.18 \
8"
9
10# Search $PWD/eglibc-2.18 for additional patches
11FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
12
13# Placeholder for patches
14SRC_URI_append_class-target = " \
15"
diff --git a/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend b/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend
new file mode 100644
index 0000000..f2bdba1
--- /dev/null
+++ b/meta-vib4-extras/recipes/linux-libc-headers/linux-libc-headers_4.1.bbappend
@@ -0,0 +1,7 @@
1# Use our kernel instead of yocto which defaults to mainline 3.18
2SRC_URI = "file://${KERN_DIR}/linux.tar.bz2"
3PV = "3.18"
4
5# Extracting linux.tar.bz2 creates directories
6# <top>/vibrante-oss-src/kernel
7S = "${WORKDIR}/vibrante-oss-src/kernel"
diff --git a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
new file mode 100644
index 0000000..8861fc3
--- /dev/null
+++ b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
@@ -0,0 +1,57 @@
1
2##############################################################################
3##
4## Copyright (C) 2016 The Qt Company Ltd.
5## Contact: http://www.qt.io/licensing/
6##
7## This file is part of the Boot to Qt meta layer.
8##
9## $QT_BEGIN_LICENSE:COMM$
10##
11## Commercial License Usage
12## Licensees holding valid commercial Qt licenses may use this file in
13## accordance with the commercial license agreement provided with the
14## Software or, alternatively, in accordance with the terms contained in
15## a written agreement between you and The Qt Company. For licensing terms
16## and conditions see http://www.qt.io/terms-conditions. For further
17## information use the contact form at http://www.qt.io/contact-us.
18##
19## $QT_END_LICENSE$
20##
21##############################################################################
22
23do_kernel_defconfig_prepend () {
24}
25
26do_compile_prepend () {
27 # cross_compile_exports
28 export ARCH=${KERNEL_ARCH}
29 export CROSS_COMPILE=${CROSS_COMPILE}
30
31 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
32 echo "CONFIG_USB_ACM=m" >> ${B}/.config
33
34 make olddefconfig
35}
36
37do_install () {
38 kernel_do_install
39
40 s=$(readlink -m "${S}")
41 kernsrc="${STAGING_KERNEL_DIR}"
42
43 if [ "${s}" != "${kernsrc}" ]; then
44 mkdir -p "${kernsrc}"
45 rm -rf "${kernsrc}"
46 mv "${S}" "${STAGING_KERNEL_DIR}"
47 ln -sf "${kernsrc}" "${s}"
48 fi
49}
50
51do_deploy() {
52 kernel_do_deploy
53}
54
55do_compile () {
56 kernel_do_compile
57}
diff --git a/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
new file mode 100644
index 0000000..629ccf4
--- /dev/null
+++ b/meta-vib4-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch
@@ -0,0 +1,18 @@
1diff --git a/configure.ac b/configure.ac
2index 97a29d6..b0e4060 100644
3--- a/configure.ac
4+++ b/configure.ac
5@@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*],
6 -Wno-gnu-variable-sized-type-not-at-end \
7 ])])
8
9-AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*],
10- [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
11- -flto -ffat-lto-objects])],
12- [AC_MSG_RESULT([skipping -flto, optimization not enabled])])
13 AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags")
14
15 AS_CASE([$CFLAGS], [*-O[[12345\ ]]*],
16--
172.5.0
18
diff --git a/meta-vib4-extras/recipes/systemd/systemd_%.bbappend b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..9b56df1
--- /dev/null
+++ b/meta-vib4-extras/recipes/systemd/systemd_%.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
new file mode 100644
index 0000000..2c46f2d
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
@@ -0,0 +1,41 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23
24SRC_URI += " \
25 file://wayland-client.pc \
26 file://wayland-cursor.pc \
27 file://wayland-egl.pc \
28 file://wayland-server.pc \
29 file://${PLATFORM_TOPDIR}/include/wayland-egl-core.h \
30 "
31
32FILES_${PN} += "${libdir}/pkgconfig"
33
34WAYLAND_PACKAGES += "wayland-dev"
35
36do_install_append() {
37 install -d ${D}${libdir}/pkgconfig
38 install -m 0776 ${WORKDIR}/*.pc ${D}${libdir}/pkgconfig
39 install -d ${D}${includedir}
40 install -m 0775 ${PLATFORM_TOPDIR}/include/wayland-egl-core.h ${D}${includedir}
41}
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc
new file mode 100644
index 0000000..e639768
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-client.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=/usr
3datarootdir=${prefix}/share
4pkgdatadir=/usr/share/wayland
5libdir=/usr/lib
6includedir=/usr/include
7
8Name: Wayland Client
9Description: Wayland client side library
10Version: 1.6.0
11Cflags: -I${includedir}
12Libs: -L${libdir} -lwayland-client
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc
new file mode 100644
index 0000000..36538ad
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-cursor.pc
@@ -0,0 +1,10 @@
1prefix=/usr
2exec_prefix=/usr
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: Wayland Cursor
7Description: Wayland cursor helper library
8Version: 1.6.0
9Cflags: -I${includedir}
10Libs: -L${libdir} -lwayland-cursor
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc
new file mode 100644
index 0000000..dc8393f
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-egl.pc
@@ -0,0 +1,11 @@
1prefix=/usr
2exec_prefix=/usr
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: wayland-egl
7Description: wayland-egl library
8Version: 9.1.6
9Libs: -L${libdir} -lwayland-egl
10Cflags: -I${includedir}
11
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc
new file mode 100644
index 0000000..dab87b9
--- /dev/null
+++ b/meta-vib4-extras/recipes/wayland-nv/wayland-nv/wayland-server.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=/usr
3datarootdir=${prefix}/share
4pkgdatadir=/usr/share/wayland
5libdir=/usr/lib
6includedir=/usr/include
7
8Name: Wayland Server
9Description: Server side implementation of the Wayland protocol
10Version: 1.6.0
11Cflags: -I${includedir}
12Libs: -L${libdir} -lwayland-server