summaryrefslogtreecommitdiffstats
path: root/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend')
-rw-r--r--meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend b/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
deleted file mode 100644
index f892961..0000000
--- a/meta-vib4-extras/recipes/wayland-nv/wayland-nv.bbappend
+++ /dev/null
@@ -1,49 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
31
32SRC_URI += " \
33 file://wayland-client.pc \
34 file://wayland-cursor.pc \
35 file://wayland-egl.pc \
36 file://wayland-server.pc \
37 file://${PLATFORM_TOPDIR}/include/wayland-egl-core.h \
38 "
39
40FILES_${PN} += "${libdir}/pkgconfig"
41
42WAYLAND_PACKAGES += "wayland-dev"
43
44do_install_append() {
45 install -d ${D}${libdir}/pkgconfig
46 install -m 0776 ${WORKDIR}/*.pc ${D}${libdir}/pkgconfig
47 install -d ${D}${includedir}
48 install -m 0775 ${PLATFORM_TOPDIR}/include/wayland-egl-core.h ${D}${includedir}
49}