summaryrefslogtreecommitdiffstats
path: root/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-vib4-extras/recipes/linux/linux-nvidia.bbappend')
-rw-r--r--meta-vib4-extras/recipes/linux/linux-nvidia.bbappend57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
new file mode 100644
index 0000000..8861fc3
--- /dev/null
+++ b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
@@ -0,0 +1,57 @@
1
2##############################################################################
3##
4## Copyright (C) 2016 The Qt Company Ltd.
5## Contact: http://www.qt.io/licensing/
6##
7## This file is part of the Boot to Qt meta layer.
8##
9## $QT_BEGIN_LICENSE:COMM$
10##
11## Commercial License Usage
12## Licensees holding valid commercial Qt licenses may use this file in
13## accordance with the commercial license agreement provided with the
14## Software or, alternatively, in accordance with the terms contained in
15## a written agreement between you and The Qt Company. For licensing terms
16## and conditions see http://www.qt.io/terms-conditions. For further
17## information use the contact form at http://www.qt.io/contact-us.
18##
19## $QT_END_LICENSE$
20##
21##############################################################################
22
23do_kernel_defconfig_prepend () {
24}
25
26do_compile_prepend () {
27 # cross_compile_exports
28 export ARCH=${KERNEL_ARCH}
29 export CROSS_COMPILE=${CROSS_COMPILE}
30
31 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
32 echo "CONFIG_USB_ACM=m" >> ${B}/.config
33
34 make olddefconfig
35}
36
37do_install () {
38 kernel_do_install
39
40 s=$(readlink -m "${S}")
41 kernsrc="${STAGING_KERNEL_DIR}"
42
43 if [ "${s}" != "${kernsrc}" ]; then
44 mkdir -p "${kernsrc}"
45 rm -rf "${kernsrc}"
46 mv "${S}" "${STAGING_KERNEL_DIR}"
47 ln -sf "${kernsrc}" "${s}"
48 fi
49}
50
51do_deploy() {
52 kernel_do_deploy
53}
54
55do_compile () {
56 kernel_do_compile
57}