summaryrefslogtreecommitdiffstats
path: root/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-vib4-extras/recipes/linux/linux-nvidia.bbappend')
-rw-r--r--meta-vib4-extras/recipes/linux/linux-nvidia.bbappend65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
new file mode 100644
index 0000000..07c9646
--- /dev/null
+++ b/meta-vib4-extras/recipes/linux/linux-nvidia.bbappend
@@ -0,0 +1,65 @@
1
2############################################################################
3##
4## Copyright (C) 2016 The Qt Company Ltd.
5## Contact: https://www.qt.io/licensing/
6##
7## This file is part of the Boot to Qt meta layer.
8##
9## $QT_BEGIN_LICENSE:GPL$
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at https://www.qt.io/contact-us.
17##
18## GNU General Public License Usage
19## Alternatively, this file may be used under the terms of the GNU
20## General Public License version 3 or (at your option) any later version
21## approved by the KDE Free Qt Foundation. The licenses are as published by
22## the Free Software Foundation and appearing in the file LICENSE.GPL3
23## included in the packaging of this file. Please review the following
24## information to ensure the GNU General Public License requirements will
25## be met: https://www.gnu.org/licenses/gpl-3.0.html.
26##
27## $QT_END_LICENSE$
28##
29############################################################################
30
31do_kernel_defconfig_prepend () {
32}
33
34do_compile_prepend () {
35 # cross_compile_exports
36 export ARCH=${KERNEL_ARCH}
37 export CROSS_COMPILE=${CROSS_COMPILE}
38
39 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
40 echo "CONFIG_USB_ACM=m" >> ${B}/.config
41
42 make olddefconfig
43}
44
45do_install () {
46 kernel_do_install
47
48 s=$(readlink -m "${S}")
49 kernsrc="${STAGING_KERNEL_DIR}"
50
51 if [ "${s}" != "${kernsrc}" ]; then
52 mkdir -p "${kernsrc}"
53 rm -rf "${kernsrc}"
54 mv "${S}" "${STAGING_KERNEL_DIR}"
55 ln -sf "${kernsrc}" "${s}"
56 fi
57}
58
59do_deploy() {
60 kernel_do_deploy
61}
62
63do_compile () {
64 kernel_do_compile
65}