summaryrefslogtreecommitdiffstats
path: root/meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend')
-rw-r--r--meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend b/meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend
new file mode 100644
index 0000000..e59898d
--- /dev/null
+++ b/meta-vib3-extras/recipes/linux/linux-nvidia_3.10.bbappend
@@ -0,0 +1,65 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "__default:${THISDIR}/${PN}:"
31
32DEPENDS_remove = "external-tegra-toolchain"
33do_kernel_defconfig[depends] = "kern-tools-native:do_populate_sysroot"
34
35SRC_URI += "\
36 file://0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch \
37 file://0001-Change-extern-inline-to-static-inline.patch \
38 file://Fix_compile_error_in_tegra_drivers.patch \
39 file://Fix_compiler_error_in_tegra12_lock.patch \
40 "
41
42do_compile_prepend () {
43 # Cross compiling exports
44 export ARCH=${TARGET_ARCH}
45 export CROSS_COMPILE=${CROSS_COMPILE}
46
47 echo "CONFIG_FHANDLE=y" >> ${B}/.config
48 make olddefconfig
49}
50
51do_install_append() {
52 s=$(readlink -m "${S}")
53 kernsrc="${STAGING_KERNEL_DIR}"
54
55 if [ "${s}" != "${kernsrc}" ]; then
56 mkdir -p "${kernsrc}"
57 rm -rf "${kernsrc}"
58 mv "${S}" "${STAGING_KERNEL_DIR}"
59 ln -sf "${kernsrc}" "${s}"
60 fi
61}
62
63python do_patch () {
64 bb.build.exec_func('patch_do_patch', d)
65}