summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/conf/layer.conf6
-rw-r--r--meta-toradex-extras/recipes/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch22
-rw-r--r--meta-toradex-extras/recipes/systemd/systemd_%.bbappend33
3 files changed, 58 insertions, 3 deletions
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf
index 3a43fd7..ef241be 100644
--- a/meta-toradex-extras/conf/layer.conf
+++ b/meta-toradex-extras/conf/layer.conf
@@ -39,8 +39,8 @@ BBFILE_COLLECTIONS += "b2qt_toradex"
39BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/" 39BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/"
40BBFILE_PRIORITY_b2qt_toradex = "20" 40BBFILE_PRIORITY_b2qt_toradex = "20"
41 41
42LAYERSERIES_COMPAT_b2qt_toradex = "sumo" 42LAYERSERIES_COMPAT_b2qt_toradex = "thud"
43 43
44# override toradex layer COMPATs 44# override toradex layer COMPATs
45LAYERSERIES_COMPAT_toradex-bsp-common-layer = "sumo" 45LAYERSERIES_COMPAT_toradex-bsp-common-layer = "thud"
46LAYERSERIES_COMPAT_toradex-nxp-layer = "sumo" 46LAYERSERIES_COMPAT_toradex-nxp-layer = "thud"
diff --git a/meta-toradex-extras/recipes/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch b/meta-toradex-extras/recipes/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
new file mode 100644
index 0000000..ef7e541
--- /dev/null
+++ b/meta-toradex-extras/recipes/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
@@ -0,0 +1,22 @@
1From 2a9d175360f1ed3ef85e336a329a9e803226096e Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.oss.09@gmail.com>
3Date: Thu, 29 Oct 2015 19:38:50 +0100
4Subject: [PATCH] systemd-udevd.service.in: set MountFlags=shared
5
6This allows for udevd automounting of drives accessible to all.
7---
8 units/systemd-udevd.service.in | 1 -
9 1 file changed, 1 deletion(-)
10
11diff --git a/units/systemd-udevd.service.in b/units/systemd-udevd.service.in
12index 6a3814e5d9..e3f3ad3293 100644
13--- a/units/systemd-udevd.service.in
14+++ b/units/systemd-udevd.service.in
15@@ -25,7 +25,6 @@ ExecStart=@rootlibexecdir@/systemd-udevd
16 KillMode=mixed
17 WatchdogSec=3min
18 TasksMax=infinity
19-PrivateMounts=yes
20 MemoryDenyWriteExecute=yes
21 RestrictRealtime=yes
22 RestrictAddressFamilies=AF_UNIX AF_NETLINK AF_INET AF_INET6
diff --git a/meta-toradex-extras/recipes/systemd/systemd_%.bbappend b/meta-toradex-extras/recipes/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..52e23dc
--- /dev/null
+++ b/meta-toradex-extras/recipes/systemd/systemd_%.bbappend
@@ -0,0 +1,33 @@
1############################################################################
2##
3## Copyright (C) 2019 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \
32 file://0001-systemd-udevd.service.in-set-MountFlags-shared.patch \
33"