diff options
Diffstat (limited to 'meta-toradex-extras/recipes')
3 files changed, 13 insertions, 1 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb index 420cfe0..bb209ad 100644 --- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb +++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb | |||
@@ -73,4 +73,4 @@ do_install[noexec] = "1" | |||
73 | do_populate_sysroot[noexec] = "1" | 73 | do_populate_sysroot[noexec] = "1" |
74 | 74 | ||
75 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 75 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
76 | COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6)" | 76 | COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6|colibri-imx7)" |
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr new file mode 100644 index 0000000..ee87e85 --- /dev/null +++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_blk.scr | |||
@@ -0,0 +1,6 @@ | |||
1 | test -n ${interface} || setenv interface mmc | ||
2 | test -n ${drive} || setenv drive 1 | ||
3 | |||
4 | setenv set_blkcnt 'setexpr blkcnt ${filesize} + 0x1ff && setexpr blkcnt ${blkcnt} / 0x200' | ||
5 | setenv update_uboot 'fatload ${interface} ${drive}:1 ${loadaddr} u-boot.imx && run set_blkcnt && mmc dev 0 0 && mmc write ${loadaddr} 2 ${blkcnt}' | ||
6 | echo 'enter "run update_uboot" to update the uboot' | ||
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr new file mode 100644 index 0000000..152982c --- /dev/null +++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/mx7/flash_mmc.scr | |||
@@ -0,0 +1,6 @@ | |||
1 | #flash_mmc has been renamed to flash_blk, ensure compatibility when updating from older versions | ||
2 | test -n ${interface} || setenv interface mmc | ||
3 | test -n ${drive} || setenv drive 1 | ||
4 | |||
5 | fatload ${interface} ${drive}:1 ${loadaddr} flash_blk.img | ||
6 | source ${loadaddr} | ||