summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend22
1 files changed, 12 insertions, 10 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
index bdae0b8..9f98fc3 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -27,16 +27,18 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30PV = "v2015.04-v2.6b2.1+git${SRCPV}"
31SRCREV_b2qt = "90a974d34aaa85d5ce69f83067928592c5389990"
32SRCBRANCH = "2015.04-toradex"
33COMPATIBLE_MACHINE = "(mx6|mx7|vf)"
34
35do_deploy_append_apalis-imx6() {
36 cd ${DEPLOYDIR}
37 ln -sf u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX} ${UBOOT_SYMLINK}-${type}
38 ln -sf u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX} ${UBOOT_BINARY}-${type}
39}
40
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 41FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \ 42SRC_URI += " \
32 file://0001-colibri-vf-remove-console-from-tty1.patch \ 43 file://0001-Make-sdboot-default-on-all-boards.patch \
33 file://0002-colibri-vf-fix-mmc-boot.patch \
34 file://0001-colibri-imx7-fix-update-u-boot.patch \
35 " 44 "
36
37do_compile_append () {
38 if [ "${MACHINE}" = "colibri-vf" ]; then
39 oe_runmake u-boot-nand.imx
40 fi
41
42}