summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb18
1 files changed, 13 insertions, 5 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
index b83e6a0..92ea3bd 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -25,16 +25,21 @@ DEPENDS = "u-boot-mkimage-native"
25 25
26PV = "v2.3" 26PV = "v2.3"
27 27
28SRC_URI = "file://flash_mmc.scr" 28SRC_URI = " \
29 file://flash_mmc.scr \
30 file://flash_blk.scr \
31 "
29 32
30inherit deploy 33inherit deploy
31 34
32UPDATESCRIPT = "${WORKDIR}/flash_mmc.scr"
33
34do_mkimage () { 35do_mkimage () {
35 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ 36 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
36 -n "update script" -d ${UPDATESCRIPT} \ 37 -n "update script" -d ${WORKDIR}/flash_mmc.scr \
37 flash_mmc.img 38 flash_mmc.img
39
40 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
41 -n "update script" -d ${WORKDIR}/flash_blk.scr \
42 flash_blk.img
38} 43}
39 44
40addtask mkimage after do_compile before do_install 45addtask mkimage after do_compile before do_install
@@ -42,10 +47,13 @@ addtask mkimage after do_compile before do_install
42do_deploy () { 47do_deploy () {
43 install -d ${DEPLOYDIR} 48 install -d ${DEPLOYDIR}
44 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img 49 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img
50 install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img
45 51
46 cd ${DEPLOYDIR} 52 cd ${DEPLOYDIR}
47 rm -f flash_mmc-${MACHINE}.img 53 rm -f flash_mmc-${MACHINE}.img
48 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img 54 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img
55 rm -f flash_blk-${MACHINE}.img
56 ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img
49} 57}
50 58
51addtask deploy after do_install before do_build 59addtask deploy after do_install before do_build
@@ -55,4 +63,4 @@ do_install[noexec] = "1"
55do_populate_sysroot[noexec] = "1" 63do_populate_sysroot[noexec] = "1"
56 64
57PACKAGE_ARCH = "${MACHINE_ARCH}" 65PACKAGE_ARCH = "${MACHINE_ARCH}"
58COMPATIBLE_MACHINE = "(apalis-imx6)" 66COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf)"