summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
new file mode 100644
index 0000000..4254062
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -0,0 +1,58 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23LICENSE = "CLOSED"
24DEPENDS = "u-boot-mkimage-native"
25
26PV = "v2.3"
27
28SRC_URI = "file://flash_mmc.scr"
29
30inherit deploy
31
32UPDATESCRIPT = "${WORKDIR}/flash_mmc.scr"
33
34do_mkimage () {
35 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
36 -n "update script" -d ${UPDATESCRIPT} \
37 flash_mmc.img
38}
39
40addtask mkimage after do_compile before do_install
41
42do_deploy () {
43 install -d ${DEPLOYDIR}
44 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img
45
46 cd ${DEPLOYDIR}
47 rm -f flash_mmc-${MACHINE}.img
48 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img
49}
50
51addtask deploy after do_install before do_build
52
53do_compile[noexec] = "1"
54do_install[noexec] = "1"
55do_populate_sysroot[noexec] = "1"
56
57PACKAGE_ARCH = "${MACHINE_ARCH}"
58COMPATIBLE_MACHINE = "(apalis-imx6)"