summaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb33
1 files changed, 15 insertions, 18 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
index bb209ad..b5d96b6 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -31,11 +31,15 @@ LICENSE = "The-Qt-Company-DCLA-2.1"
31LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" 31LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
32DEPENDS = "u-boot-mkimage-native" 32DEPENDS = "u-boot-mkimage-native"
33 33
34PV = "v2.3" 34PV = "v2.6"
35 35
36SRC_URI = " \ 36SRC_URI = " \
37 file://flash_mmc.scr \ 37 file://fwd_mmc.scr \
38 file://fwd_blk.scr \
39 file://fwd_eth.scr \
38 file://flash_blk.scr \ 40 file://flash_blk.scr \
41 file://flash_eth.scr \
42 file://0001-Update-only-u-boot.patch \
39 " 43 "
40 44
41S = "${WORKDIR}" 45S = "${WORKDIR}"
@@ -43,27 +47,20 @@ S = "${WORKDIR}"
43inherit deploy 47inherit deploy
44 48
45do_mkimage () { 49do_mkimage () {
46 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ 50 for scr in ${WORKDIR}/*.scr; do
47 -n "update script" -d ${WORKDIR}/flash_mmc.scr \ 51 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
48 flash_mmc.img 52 -n "update script" -d ${scr} \
49 53 $(basename ${scr} .scr).img
50 uboot-mkimage -A arm -O linux -T script -C none -a 0 -e 0 \ 54 done
51 -n "update script" -d ${WORKDIR}/flash_blk.scr \
52 flash_blk.img
53} 55}
54 56
55addtask mkimage after do_compile before do_install 57addtask mkimage after do_compile before do_install
56 58
57do_deploy () { 59do_deploy () {
58 install -d ${DEPLOYDIR} 60 install -d ${DEPLOYDIR}/${MACHINE}
59 install ${S}/flash_mmc.img ${DEPLOYDIR}/flash_mmc-${MACHINE}-${PV}-${PR}.img 61 install -m 0644 -t ${DEPLOYDIR} ${S}/*.img
60 install ${S}/flash_blk.img ${DEPLOYDIR}/flash_blk-${MACHINE}-${PV}-${PR}.img 62 ln -s ../flash_blk.img ${DEPLOYDIR}/${MACHINE}/
61 63 ln -s ../flash_eth.img ${DEPLOYDIR}/${MACHINE}/
62 cd ${DEPLOYDIR}
63 rm -f flash_mmc-${MACHINE}.img
64 ln -sf flash_mmc-${MACHINE}-${PV}-${PR}.img flash_mmc-${MACHINE}.img
65 rm -f flash_blk-${MACHINE}.img
66 ln -sf flash_blk-${MACHINE}-${PV}-${PR}.img flash_blk-${MACHINE}.img
67} 64}
68 65
69addtask deploy after do_install before do_build 66addtask deploy after do_install before do_build