summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb')
-rw-r--r--meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb b/meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb
new file mode 100644
index 0000000..5695561
--- /dev/null
+++ b/meta-ti-extras/recipes/u-boot/u-boot-uenv-script.bb
@@ -0,0 +1,48 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "U-Boot script to start up BeagleBone Black"
23LICENSE = "CLOSED"
24PR = "r0"
25
26COMPATIBLE_MACHINE = "(beaglebone)"
27PV = "20140225"
28
29SRC_URI = "file://uEnv.txt"
30
31inherit deploy
32
33do_deploy () {
34 install -d ${DEPLOYDIR}
35 install ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv-${MACHINE}-${PV}-${PR}.txt
36
37 cd ${DEPLOYDIR}
38 rm -f uEnv-${MACHINE}.txt
39 ln -sf uEnv-${MACHINE}-${PV}-${PR}.txt uEnv-${MACHINE}.txt
40}
41
42addtask deploy after do_install before do_build
43
44do_compile[noexec] = "1"
45do_install[noexec] = "1"
46do_populate_sysroot[noexec] = "1"
47
48PACKAGE_ARCH = "${MACHINE_ARCH}"