summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend')
-rw-r--r--meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
deleted file mode 100644
index 0b4beff..0000000
--- a/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
+++ /dev/null
@@ -1,40 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23do_configure_append() {
24 # FunctionFS for adb
25 echo "CONFIG_USB_LIBCOMPOSITE=y" >> ${S}/.config
26 echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
27 echo "CONFIG_USB_FUNCTIONFS_ETH=n" >> ${S}/.config
28 echo "CONFIG_USB_FUNCTIONFS_RNDIS=n" >> ${S}/.config
29 echo "CONFIG_USB_FUNCTIONFS_GENERIC=y" >> ${S}/.config
30
31 echo "CONFIG_DEVTMPFS=y" >> ${S}/.config
32
33 # Enable USB serial support
34 echo "CONFIG_USB_SERIAL=m" >> ${S}/.config
35 echo "CONFIG_USB_SERIAL_GENERIC=y" >> ${S}/.config
36 echo "CONFIG_USB_SERIAL_FTDI_SIO=m" >> ${S}/.config
37 echo "CONFIG_USB_SERIAL_PL2303=m" >> ${S}/.config
38
39 yes '' | oe_runmake oldconfig
40}