diff options
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r-- | meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc | 11 | ||||
-rw-r--r-- | meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend | 40 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc new file mode 100644 index 0000000..6fe139e --- /dev/null +++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc | |||
@@ -0,0 +1,11 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=${exec_prefix}/lib | ||
4 | includedir=${prefix}/include | ||
5 | |||
6 | Name: libdrm | ||
7 | Description: Userspace interface to kernel DRM services | ||
8 | Version: 2.4.66 | ||
9 | Libs: -L${libdir} -ldrm | ||
10 | Cflags: -I${includedir} -I${includedir}/libdrm | ||
11 | |||
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend new file mode 100644 index 0000000..f346a6b --- /dev/null +++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend | |||
@@ -0,0 +1,40 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}:" | ||
31 | |||
32 | SRC_URI += " file://libdrm.pc" | ||
33 | SRC_URI_remove_nvidia-logan = "file://${PLATFORM_TOPDIR}/include/drm_fourcc.h" | ||
34 | |||
35 | do_install_append() { | ||
36 | install -d ${D}/usr/lib/pkgconfig | ||
37 | install -m 0776 ${WORKDIR}/libdrm.pc ${D}/usr/lib/pkgconfig/libdrm.pc | ||
38 | } | ||
39 | |||
40 | PACKAGES += "${PN}-dev" | ||