summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tegra-extras')
-rw-r--r--meta-tegra-extras/conf/layer.conf32
-rw-r--r--meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend32
-rw-r--r--meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf4
-rw-r--r--meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend25
-rw-r--r--meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend27
-rw-r--r--meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend22
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc11
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend32
-rw-r--r--meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend23
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc12
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend41
11 files changed, 261 insertions, 0 deletions
diff --git a/meta-tegra-extras/conf/layer.conf b/meta-tegra-extras/conf/layer.conf
new file mode 100644
index 0000000..b4a9671
--- /dev/null
+++ b/meta-tegra-extras/conf/layer.conf
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28"
29
30BBFILE_COLLECTIONS += "b2qt_tegra"
31BBFILE_PATTERN_b2qt_tegra := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_tegra = "20"
diff --git a/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend b/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend
new file mode 100644
index 0000000..86f0571
--- /dev/null
+++ b/meta-tegra-extras/recipes/connman-conf/connman-conf.bbappend
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23
24FILES_${PN} += "etc/connman/main.conf"
25
26SRC_URI += "file://main.conf \
27 "
28
29do_install_append() {
30 install -d ${D}${sysconfdir}/connman
31 install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf
32}
diff --git a/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf b/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf
new file mode 100644
index 0000000..a1e45b9
--- /dev/null
+++ b/meta-tegra-extras/recipes/connman-conf/connman-conf/main.conf
@@ -0,0 +1,4 @@
1[General]
2PreferredTechnologies=ethernet,wifi,cellular
3NetworkInterfaceBlacklist=eth0
4
diff --git a/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend b/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
new file mode 100644
index 0000000..9544e7b
--- /dev/null
+++ b/meta-tegra-extras/recipes/egl-gles-nv/egl-gles-nv_1.0.bbappend
@@ -0,0 +1,25 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22PROVIDES = "virtual/egl virtual/libgles2"
23RPROVIDES_${PN} = "libegl libegl-dev libgles2 libgles2-dev"
24RCONFLICTS_${PN} = "libegl-mesa libegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
25RREPLACES_${PN} = "libegl-mesa lbegl-mesa-dev libgles2-mesa libgles2-mesa-dev"
diff --git a/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend b/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend
new file mode 100644
index 0000000..5d0b777
--- /dev/null
+++ b/meta-tegra-extras/recipes/firmware/tegra-firmware_1.0.bbappend
@@ -0,0 +1,27 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# WARNING: FILESEXTRAPATHS-variable, must always use _prepend (or _append)
23FILESEXTRAPATHS_tegra-x1_prepend = "__default:"
24FILESEXTRAPATHS_tegra-t18x_prepend = "__default:"
25
26# ERROR: QA Issue: Files/directories were installed but not shipped in any package
27FILES_${PN}-gk20a = "${FILES__${PN}-gk20a}"
diff --git a/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend b/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
new file mode 100644
index 0000000..4c839e2
--- /dev/null
+++ b/meta-tegra-extras/recipes/graphics-headers/graphics-headers_1.0.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
new file mode 100644
index 0000000..6fe139e
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv/libdrm.pc
@@ -0,0 +1,11 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=${exec_prefix}/lib
4includedir=${prefix}/include
5
6Name: libdrm
7Description: Userspace interface to kernel DRM services
8Version: 2.4.66
9Libs: -L${libdir} -ldrm
10Cflags: -I${includedir} -I${includedir}/libdrm
11
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
new file mode 100644
index 0000000..fdef52d
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23
24SRC_URI += " file://libdrm.pc"
25SRC_URI_remove_nvidia-logan = "file://${PLATFORM_TOPDIR}/include/drm_fourcc.h"
26
27do_install_append() {
28 install -d ${D}/usr/lib/pkgconfig
29 install -m 0776 ${WORKDIR}/libdrm.pc ${D}/usr/lib/pkgconfig/libdrm.pc
30}
31
32PACKAGES += "${PN}-dev"
diff --git a/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend
new file mode 100644
index 0000000..97acf20
--- /dev/null
+++ b/meta-tegra-extras/recipes/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,23 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM"
23COMPATIBLE_MACHINE_aarch64 = "(.*)"
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
new file mode 100644
index 0000000..da1f5f7
--- /dev/null
+++ b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: egl
7Description: Mesa EGL library
8Requires.private: libdrm >= 2.4.24
9Version: 9.1.6
10Libs: -L${libdir} -lEGL
11Libs.private: -lm -lpthread -ldl
12Cflags: -I${includedir}
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
new file mode 100644
index 0000000..fbee576
--- /dev/null
+++ b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
@@ -0,0 +1,41 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23
24SRC_URI += " file://egl.pc"
25FILES_${PN} += "egl.pc"
26
27GRAPHICS_PACKAGES = " \
28 virtual/libgles2 \
29 virtual/libegl \
30 virtual/egl \
31 virtual/libgl \
32 virtual/libgles1 \
33 virtual/mesa \
34 libgbm \
35 libgbm-dev \
36 "
37
38do_install_append_tegra-t18x() {
39 install -d ${D}/usr/lib/pkgconfig
40 install -m 0775 ${WORKDIR}/egl.pc ${D}/${libdir}/pkgconfig
41}