summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tegra-extras/recipes')
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch46
-rw-r--r--meta-tegra-extras/recipes/qt5/qtbase_git.bbappend6
2 files changed, 50 insertions, 2 deletions
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch b/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
new file mode 100644
index 0000000..1bce6d7
--- /dev/null
+++ b/meta-tegra-extras/recipes/linux/linux-tegra/jetson-tx2/0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch
@@ -0,0 +1,46 @@
1From 75a27373962e24424bcd2781568e6c6c5715ca92 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Ilari=20=C3=84ngeslev=C3=A4?= <ilari.angesleva@qt.io>
3Date: Tue, 17 Oct 2017 14:13:02 +0300
4Subject: [PATCH] fbcon: Compare variable screen info instead of modes (FIX)
5
6Previous commit changed behavior, so that when trying to match a mode to a
7variable screen info structure, the mode was first converted to a variable
8screen structure rather than the variable screen info structure to a mode.
9
10However, when new mode was being added to the modelist, matching was still
11being done using mode structure. This could cause situation, where existing
12mode would match when comparing with mode structure, but not when compared
13using variable screen info structure. This would eventually result in a
14NULL pointer dereference in fbcon_switch.
15
16Fix the issue by using the variable screen info structure also when adding
17new mode to the modelist.
18---
19 drivers/video/fbdev/core/modedb.c | 7 ++++---
20 1 file changed, 4 insertions(+), 3 deletions(-)
21
22diff --git a/drivers/video/fbdev/core/modedb.c b/drivers/video/fbdev/core/modedb.c
23index f5a53a6..a8fd871 100644
24--- a/drivers/video/fbdev/core/modedb.c
25+++ b/drivers/video/fbdev/core/modedb.c
26@@ -2187,13 +2187,14 @@ int fb_add_videomode(const struct fb_videomode *mode, struct list_head *head)
27 {
28 struct list_head *pos;
29 struct fb_modelist *modelist;
30- struct fb_videomode *m;
31+ struct fb_var_screeninfo v1, v2;
32 int found = 0;
33
34+ fb_videomode_to_var(&v1, mode);
35 list_for_each(pos, head) {
36 modelist = list_entry(pos, struct fb_modelist, list);
37- m = &modelist->mode;
38- if (fb_mode_is_equal(m, mode)) {
39+ fb_videomode_to_var(&v2, &modelist->mode);
40+ if (fb_var_is_equal(&v1, &v2)) {
41 found = 1;
42 break;
43 }
44--
452.7.4
46
diff --git a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
index ae323cf..5b9f84b 100644
--- a/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
+++ b/meta-tegra-extras/recipes/qt5/qtbase_git.bbappend
@@ -29,5 +29,7 @@
29 29
30PACKAGECONFIG += "kms" 30PACKAGECONFIG += "kms"
31 31
32# Disable getentropy because of older than 3.17 kernel 32# Disable getentropy for jetson-tx1 because of older than 3.17 kernel.
33QT_CONFIG_FLAGS += "--no-feature-getentropy" 33# The kernel version in jetson-tx2 is 4.4.
34
35QT_CONFIG_FLAGS_append_jetson-tx1 = " --no-feature-getentropy"