summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras/recipes/tegra-drivers
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tegra-extras/recipes/tegra-drivers')
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc12
-rw-r--r--meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend41
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
new file mode 100644
index 0000000..da1f5f7
--- /dev/null
+++ b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers/egl.pc
@@ -0,0 +1,12 @@
1prefix=/usr
2exec_prefix=${prefix}
3libdir=/usr/lib
4includedir=/usr/include
5
6Name: egl
7Description: Mesa EGL library
8Requires.private: libdrm >= 2.4.24
9Version: 9.1.6
10Libs: -L${libdir} -lEGL
11Libs.private: -lm -lpthread -ldl
12Cflags: -I${includedir}
diff --git a/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
new file mode 100644
index 0000000..fbee576
--- /dev/null
+++ b/meta-tegra-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend
@@ -0,0 +1,41 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23
24SRC_URI += " file://egl.pc"
25FILES_${PN} += "egl.pc"
26
27GRAPHICS_PACKAGES = " \
28 virtual/libgles2 \
29 virtual/libegl \
30 virtual/egl \
31 virtual/libgl \
32 virtual/libgles1 \
33 virtual/mesa \
34 libgbm \
35 libgbm-dev \
36 "
37
38do_install_append_tegra-t18x() {
39 install -d ${D}/usr/lib/pkgconfig
40 install -m 0775 ${WORKDIR}/egl.pc ${D}/${libdir}/pkgconfig
41}