summaryrefslogtreecommitdiffstats
path: root/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend')
-rw-r--r--meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
new file mode 100644
index 0000000..fdef52d
--- /dev/null
+++ b/meta-tegra-extras/recipes/libdrm-nv/libdrm-nv_1.0.bbappend
@@ -0,0 +1,32 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
23
24SRC_URI += " file://libdrm.pc"
25SRC_URI_remove_nvidia-logan = "file://${PLATFORM_TOPDIR}/include/drm_fourcc.h"
26
27do_install_append() {
28 install -d ${D}/usr/lib/pkgconfig
29 install -m 0776 ${WORKDIR}/libdrm.pc ${D}/usr/lib/pkgconfig/libdrm.pc
30}
31
32PACKAGES += "${PN}-dev"