summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/vspm-module
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/vspm-module')
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb61
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend30
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb63
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend30
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend30
5 files changed, 214 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
new file mode 100755
index 0000000..ff20028
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
@@ -0,0 +1,61 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = " \
32file://GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34"
35
36SRC_URI = " \
37 git://github.com/renesas-devel/vsp2driver.git;protocol=git;branch=RCAR-GEN2/1.0.0 \
38 file://vsp2drv-init \
39"
40SRCREV = "8cc362a6c961661e4655904f8d7731e501529d6c"
41S = "${WORKDIR}/git"
42
43DEPENDS = "vspm-kernel-module"
44do_configure[depends] += "vspm-kernel-module:do_shared_workdir"
45
46MODULE_NAME = "vsp2"
47INITSCRIPT_NAME = "vsp2drv"
48INITSCRIPT_PARAMS = "start 8 5 2 . stop 61 0 1 6 ."
49
50inherit renesas-module update-rc.d
51
52do_compile_prepend() {
53 export VSP2_VSPMDIR=${STAGING_KERNEL_BUILDDIR}/include
54 export VSP2_VSPMSYMVERS=vspm.symvers
55}
56
57do_install_append() {
58 install -D -m 0755 ${WORKDIR}/vsp2drv-init ${D}/${sysconfdir}/init.d/vsp2drv
59}
60
61FILES_${PN} += "/etc/init.d/vsp2drv"
diff --git a/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend
new file mode 100644
index 0000000..509317a
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/meta-renesas/meta-rcar-gen2/recipes-kernel/vspm-module/files:"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
new file mode 100755
index 0000000..05518fa
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
@@ -0,0 +1,63 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = "\
32file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34"
35
36SRC_URI = "file://vspm-kernel.tar.bz2"
37S = "${WORKDIR}/vspm"
38
39inherit renesas-module
40
41MODULE_NAME = "vspm"
42MODULE_HEADERS = " \
43include/vspm_public.h \
44include/vsp_drv.h \
45include/tddmac_drv.h \
46include/vspm_if.h \
47"
48
49VSPM_CFG_r8a7790 = "H2CONFIG"
50VSPM_CFG_r8a7791 = "M2CONFIG"
51VSPM_CFG_r8a7793 = "M2CONFIG"
52VSPM_CFG_r8a7794 = "E2CONFIG"
53
54do_compile_prepend() {
55 export VSPM_CONFIG=${VSPM_CFG}
56}
57
58do_install_append() {
59 # Copy for vspm-user-module
60 install -t ${STAGING_INCDIR} ${S}/include/vspm_if.h
61}
62
63FILES_${PN}-dev += "/usr/include/vspm_if.h"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend
new file mode 100644
index 0000000..509317a
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/meta-renesas/meta-rcar-gen2/recipes-kernel/vspm-module/files:"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend
new file mode 100644
index 0000000..2c0744f
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend
@@ -0,0 +1,30 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_compile[depends] += "vspm-kernel-module:do_shared_workdir"