summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/vspm-module
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/vspm-module')
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb53
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend22
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb55
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend22
-rw-r--r--meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend22
5 files changed, 174 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
new file mode 100755
index 0000000..622acf9
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
@@ -0,0 +1,53 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22LICENSE = "GPLv2 & MIT"
23LIC_FILES_CHKSUM = " \
24file://GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
25file://MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
26"
27
28SRC_URI = " \
29 git://github.com/renesas-devel/vsp2driver.git;protocol=git;branch=RCAR-GEN2/1.0.0 \
30 file://vsp2drv-init \
31"
32SRCREV = "8cc362a6c961661e4655904f8d7731e501529d6c"
33S = "${WORKDIR}/git"
34
35DEPENDS = "vspm-kernel-module"
36do_configure[depends] += "vspm-kernel-module:do_shared_workdir"
37
38MODULE_NAME = "vsp2"
39INITSCRIPT_NAME = "vsp2drv"
40INITSCRIPT_PARAMS = "start 8 5 2 . stop 61 0 1 6 ."
41
42inherit renesas-module update-rc.d
43
44do_compile_prepend() {
45 export VSP2_VSPMDIR=${STAGING_KERNEL_BUILDDIR}/include
46 export VSP2_VSPMSYMVERS=vspm.symvers
47}
48
49do_install_append() {
50 install -D -m 0755 ${WORKDIR}/vsp2drv-init ${D}/${sysconfdir}/init.d/vsp2drv
51}
52
53FILES_${PN} += "/etc/init.d/vsp2drv"
diff --git a/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend
new file mode 100644
index 0000000..168c037
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/meta-renesas/meta-rcar-gen2/recipes-kernel/vspm-module/files:"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
new file mode 100755
index 0000000..b08a589
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
@@ -0,0 +1,55 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22LICENSE = "GPLv2 & MIT"
23LIC_FILES_CHKSUM = "\
24file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
25file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
26"
27
28SRC_URI = "file://vspm-kernel.tar.bz2"
29S = "${WORKDIR}/vspm"
30
31inherit renesas-module
32
33MODULE_NAME = "vspm"
34MODULE_HEADERS = " \
35include/vspm_public.h \
36include/vsp_drv.h \
37include/tddmac_drv.h \
38include/vspm_if.h \
39"
40
41VSPM_CFG_r8a7790 = "H2CONFIG"
42VSPM_CFG_r8a7791 = "M2CONFIG"
43VSPM_CFG_r8a7793 = "M2CONFIG"
44VSPM_CFG_r8a7794 = "E2CONFIG"
45
46do_compile_prepend() {
47 export VSPM_CONFIG=${VSPM_CFG}
48}
49
50do_install_append() {
51 # Copy for vspm-user-module
52 install -t ${STAGING_INCDIR} ${S}/include/vspm_if.h
53}
54
55FILES_${PN}-dev += "/usr/include/vspm_if.h"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend
new file mode 100644
index 0000000..168c037
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/meta-renesas/meta-rcar-gen2/recipes-kernel/vspm-module/files:"
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend b/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend
new file mode 100644
index 0000000..afd5a47
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-user-module.bbappend
@@ -0,0 +1,22 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22do_compile[depends] += "vspm-kernel-module:do_shared_workdir"