summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
new file mode 100755
index 0000000..b08a589
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vspm-kernel-module.bb
@@ -0,0 +1,55 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22LICENSE = "GPLv2 & MIT"
23LIC_FILES_CHKSUM = "\
24file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
25file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
26"
27
28SRC_URI = "file://vspm-kernel.tar.bz2"
29S = "${WORKDIR}/vspm"
30
31inherit renesas-module
32
33MODULE_NAME = "vspm"
34MODULE_HEADERS = " \
35include/vspm_public.h \
36include/vsp_drv.h \
37include/tddmac_drv.h \
38include/vspm_if.h \
39"
40
41VSPM_CFG_r8a7790 = "H2CONFIG"
42VSPM_CFG_r8a7791 = "M2CONFIG"
43VSPM_CFG_r8a7793 = "M2CONFIG"
44VSPM_CFG_r8a7794 = "E2CONFIG"
45
46do_compile_prepend() {
47 export VSPM_CONFIG=${VSPM_CFG}
48}
49
50do_install_append() {
51 # Copy for vspm-user-module
52 install -t ${STAGING_INCDIR} ${S}/include/vspm_if.h
53}
54
55FILES_${PN}-dev += "/usr/include/vspm_if.h"