summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
new file mode 100755
index 0000000..ff20028
--- /dev/null
+++ b/meta-renesas-extras/recipes/vspm-module/vsp2-kernel-module.bb
@@ -0,0 +1,61 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = " \
32file://GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34"
35
36SRC_URI = " \
37 git://github.com/renesas-devel/vsp2driver.git;protocol=git;branch=RCAR-GEN2/1.0.0 \
38 file://vsp2drv-init \
39"
40SRCREV = "8cc362a6c961661e4655904f8d7731e501529d6c"
41S = "${WORKDIR}/git"
42
43DEPENDS = "vspm-kernel-module"
44do_configure[depends] += "vspm-kernel-module:do_shared_workdir"
45
46MODULE_NAME = "vsp2"
47INITSCRIPT_NAME = "vsp2drv"
48INITSCRIPT_PARAMS = "start 8 5 2 . stop 61 0 1 6 ."
49
50inherit renesas-module update-rc.d
51
52do_compile_prepend() {
53 export VSP2_VSPMDIR=${STAGING_KERNEL_BUILDDIR}/include
54 export VSP2_VSPMSYMVERS=vspm.symvers
55}
56
57do_install_append() {
58 install -D -m 0755 ${WORKDIR}/vsp2drv-init ${D}/${sysconfdir}/init.d/vsp2drv
59}
60
61FILES_${PN} += "/etc/init.d/vsp2drv"