summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb b/meta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb
new file mode 100755
index 0000000..0fe9aad
--- /dev/null
+++ b/meta-renesas-extras/recipes/uvcs-module/uvcs-kernel-module.bb
@@ -0,0 +1,48 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = "\
32file://include/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://include/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34"
35
36SRC_URI = "file://uvcs-kernel.tar.bz2"
37S = "${WORKDIR}/uvcs"
38
39inherit renesas-module
40
41export UVCS_DRV_SRC_DIR = "${S}/source/uvcs_lkm"
42export UVCS_CMN_SRC_DIR = "${S}/source/uvcs_cmn"
43export UVCS_CMN_INC_DIR = "${S}/include"
44export DRV_CORE_SRC_DIR = "${S}/source/driver_core"
45
46MODULE_NAME = "uvcs_cmn"
47MODULE_HEADERS = "include/uvcs_cmn.h include/uvcs_types.h"
48MODULE_SOURCE_DIR = "${S}/source/makefile/linaro_4_7_3/"