summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend')
-rw-r--r--meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend b/meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend
new file mode 100644
index 0000000..ff5988e
--- /dev/null
+++ b/meta-renesas-extras/recipes/omx-module/omx-user-module.bbappend
@@ -0,0 +1,33 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# The recipe adds an unpack_append where it creates the folder, but by then
23# base.bbclass will have reported a non-existent directory warning.
24do_unpack_prepend() {
25 bb.utils.mkdirhier(d.getVar('S', True))
26}
27
28do_configure[depends] += "\
29 mmngr-kernel-module:do_shared_workdir \
30 vspm-kernel-module:do_shared_workdir \
31 s3ctl-kernel-module:do_shared_workdir \
32 fdpm-kernel-module:do_shared_workdir \
33 uvcs-kernel-module:do_shared_workdir"