summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb b/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
new file mode 100755
index 0000000..4fe274b
--- /dev/null
+++ b/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
@@ -0,0 +1,46 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22LICENSE = "GPLv2 & MIT"
23LIC_FILES_CHKSUM = "\
24file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
25file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
26file://include/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
27file://include/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
28"
29
30SRC_URI = "file://mmngr.tar.bz2"
31S = "${WORKDIR}/mmngr"
32
33inherit renesas-module
34
35MODULE_NAME = "mmngr"
36MODULE_HEADERS = "include/mmngr_public.h include/mmngr_private.h"
37
38MMNGR_CFG_r8a7790 = "MMNGR_LAGER"
39MMNGR_CFG_r8a7791 = "MMNGR_KOELSCH"
40MMNGR_CFG_r8a7793 = "MMNGR_GOSE"
41MMNGR_CFG_r8a7794 = "MMNGR_ALT"
42
43do_compile_prepend() {
44 export MMNGR_CONFIG=${MMNGR_CFG}
45 export MMNGR_SSP_CONFIG="MMNGR_SSP_DISABLE"
46}