summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb b/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
deleted file mode 100755
index b21afe4..0000000
--- a/meta-renesas-extras/recipes/mmngr-module/mmngr-kernel-module.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = "\
32file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34file://include/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
35file://include/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
36"
37
38SRC_URI = "file://mmngr.tar.bz2"
39S = "${WORKDIR}/mmngr"
40
41inherit renesas-module
42
43MODULE_NAME = "mmngr"
44MODULE_HEADERS = "include/mmngr_public.h include/mmngr_private.h"
45
46MMNGR_CFG_r8a7790 = "MMNGR_LAGER"
47MMNGR_CFG_r8a7791 = "MMNGR_KOELSCH"
48MMNGR_CFG_r8a7793 = "MMNGR_GOSE"
49MMNGR_CFG_r8a7794 = "MMNGR_ALT"
50
51do_compile_prepend() {
52 export MMNGR_CONFIG=${MMNGR_CFG}
53 export MMNGR_SSP_CONFIG="MMNGR_SSP_DISABLE"
54}