diff options
Diffstat (limited to 'meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb')
-rwxr-xr-x | meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb b/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb new file mode 100755 index 0000000..b1077f1 --- /dev/null +++ b/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | LICENSE = "GPLv2 & MIT" | ||
23 | LIC_FILES_CHKSUM = "\ | ||
24 | file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
25 | file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \ | ||
26 | file://include/GPL-COPYING;md5=ffa10f40b98be2c2bc9608f56827ed23 \ | ||
27 | file://include/MIT-COPYING;md5=5526ef6e21dc96a1dd89fac4bde9f995 \ | ||
28 | " | ||
29 | |||
30 | DEPENDS = "mmngr-kernel-module" | ||
31 | SRC_URI = "file://fdpm-kernel.tar.bz2" | ||
32 | S = "${WORKDIR}/fdpm" | ||
33 | |||
34 | do_configure[depends] += "mmngr-kernel-module:do_shared_workdir" | ||
35 | |||
36 | inherit renesas-module | ||
37 | |||
38 | FDPM_CFG_r8a7790 = "H2CONFIG" | ||
39 | FDPM_CFG_r8a7791 = "M2CONFIG" | ||
40 | FDPM_CFG_r8a7793 = "M2CONFIG" | ||
41 | FDPM_CFG_r8a7794 = "E2CONFIG" | ||
42 | |||
43 | MODULE_NAME = "fdpm" | ||
44 | MODULE_HEADERS = "include/fdpm_drv.h include/fdpm_public.h include/fdpm_api.h" | ||
45 | |||
46 | do_compile_prepend() { | ||
47 | export FDPM_CONFIG=${FDPM_CFG} | ||
48 | export FDPM_MMNGRDIR=${STAGING_KERNEL_BUILDDIR}/include | ||
49 | export FDPM_MMNGRSYMVERS=mmngr.symvers | ||
50 | } | ||