summaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb')
-rwxr-xr-xmeta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb b/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb
new file mode 100755
index 0000000..6b48c83
--- /dev/null
+++ b/meta-renesas-extras/recipes/fdpm-module/fdpm-kernel-module.bb
@@ -0,0 +1,58 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30LICENSE = "GPLv2 & MIT"
31LIC_FILES_CHKSUM = "\
32file://drv/GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
33file://drv/MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
34file://include/GPL-COPYING;md5=ffa10f40b98be2c2bc9608f56827ed23 \
35file://include/MIT-COPYING;md5=5526ef6e21dc96a1dd89fac4bde9f995 \
36"
37
38DEPENDS = "mmngr-kernel-module"
39SRC_URI = "file://fdpm-kernel.tar.bz2"
40S = "${WORKDIR}/fdpm"
41
42do_configure[depends] += "mmngr-kernel-module:do_shared_workdir"
43
44inherit renesas-module
45
46FDPM_CFG_r8a7790 = "H2CONFIG"
47FDPM_CFG_r8a7791 = "M2CONFIG"
48FDPM_CFG_r8a7793 = "M2CONFIG"
49FDPM_CFG_r8a7794 = "E2CONFIG"
50
51MODULE_NAME = "fdpm"
52MODULE_HEADERS = "include/fdpm_drv.h include/fdpm_public.h include/fdpm_api.h"
53
54do_compile_prepend() {
55 export FDPM_CONFIG=${FDPM_CFG}
56 export FDPM_MMNGRDIR=${STAGING_KERNEL_BUILDDIR}/include
57 export FDPM_MMNGRSYMVERS=mmngr.symvers
58}