diff options
Diffstat (limited to 'meta-nvidia-extras')
11 files changed, 0 insertions, 186 deletions
diff --git a/meta-nvidia-extras/conf/layer.conf b/meta-nvidia-extras/conf/layer.conf deleted file mode 100644 index aa447a5..0000000 --- a/meta-nvidia-extras/conf/layer.conf +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | # We have a conf and classes directory, append to BBPATH | ||
23 | BBPATH .= ":${LAYERDIR}" | ||
24 | |||
25 | # We have a recipes directory, add to BBFILES | ||
26 | BBFILES += "${LAYERDIR}/recipes*/*/*.bb \ | ||
27 | ${LAYERDIR}/recipes*/*/*.bbappend \ | ||
28 | " | ||
29 | |||
30 | BBFILE_COLLECTIONS += "b2qt_nvidia" | ||
31 | BBFILE_PATTERN_b2qt_nvidia := "^${LAYERDIR}/" | ||
32 | BBFILE_PRIORITY_b2qt_nvidia = "20" | ||
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend b/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend deleted file mode 100644 index 86f0571..0000000 --- a/meta-nvidia-extras/recipes/connman-conf/connman-conf.bbappend +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
23 | |||
24 | FILES_${PN} += "etc/connman/main.conf" | ||
25 | |||
26 | SRC_URI += "file://main.conf \ | ||
27 | " | ||
28 | |||
29 | do_install_append() { | ||
30 | install -d ${D}${sysconfdir}/connman | ||
31 | install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman/main.conf | ||
32 | } | ||
diff --git a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf b/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf deleted file mode 100644 index a1e45b9..0000000 --- a/meta-nvidia-extras/recipes/connman-conf/connman-conf/nvidia-logan/main.conf +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | [General] | ||
2 | PreferredTechnologies=ethernet,wifi,cellular | ||
3 | NetworkInterfaceBlacklist=eth0 | ||
4 | |||
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend deleted file mode 100644 index f9d9cc6..0000000 --- a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | do_kernel_defconfig_prepend_tegra-t18x () { | ||
2 | } | ||
3 | |||
4 | do_install_append_tegra-t18x () { | ||
5 | s=$(readlink -m "${S}") | ||
6 | kernsrc="${STAGING_KERNEL_DIR}" | ||
7 | |||
8 | if [ "${s}" != "${kernsrc}" ]; then | ||
9 | mkdir -p "${kernsrc}" | ||
10 | rm -rf "${kernsrc}" | ||
11 | mv "${S}" "${STAGING_KERNEL_DIR}" | ||
12 | ln -sf "${kernsrc}" "${s}" | ||
13 | fi | ||
14 | } | ||
15 | |||
16 | do_compile_prepend_tegra-t18x () { | ||
17 | if [ -z "${TOOLCHAIN_PATH}" ] ; then | ||
18 | echo "TOOLCHAIN_PATH must be set" | ||
19 | exit -1 | ||
20 | fi | ||
21 | |||
22 | export PATH="${TOOLCHAIN_PATH}/usr/bin/aarch64-gnu-linux:${PATH}" | ||
23 | |||
24 | echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config | ||
25 | echo "CONFIG_USB_ACM=m" >> ${B}/.config | ||
26 | |||
27 | make olddefconfig | ||
28 | } | ||
diff --git a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend b/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend deleted file mode 100644 index 1800e5e..0000000 --- a/meta-nvidia-extras/recipes/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bbappend +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | RDEPENDS_${PN}_remove_tegra-t18x = "\ | ||
2 | libgbm-dev \ | ||
3 | " | ||
4 | |||
diff --git a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend deleted file mode 100644 index cd74ddf..0000000 --- a/meta-nvidia-extras/recipes/qt5/qtbase_git.bbappend +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DEPENDS_nvidia-logan += "graphics-headers" | ||
23 | PACKAGECONFIG_nvidia-logan += "kms" | ||
diff --git a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend deleted file mode 100644 index 97acf20..0000000 --- a/meta-nvidia-extras/recipes/qt5/qtwebengine_git.bbappend +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | CXXFLAGS +=" -DWIN_INTERFACE_CUSTOM" | ||
23 | COMPATIBLE_MACHINE_aarch64 = "(.*)" | ||
diff --git a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch b/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch deleted file mode 100644 index 629ccf4..0000000 --- a/meta-nvidia-extras/recipes/systemd/systemd/tegra-t18x/0001-Disable-LTO-in-LDFLAGS-and-CFLAGS.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | diff --git a/configure.ac b/configure.ac | ||
2 | index 97a29d6..b0e4060 100644 | ||
3 | --- a/configure.ac | ||
4 | +++ b/configure.ac | ||
5 | @@ -208,10 +208,6 @@ AS_CASE([$CC], [*clang*], | ||
6 | -Wno-gnu-variable-sized-type-not-at-end \ | ||
7 | ])]) | ||
8 | |||
9 | -AS_CASE([$CFLAGS], [*-O[[12345sz\ ]]*], | ||
10 | - [CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\ | ||
11 | - -flto -ffat-lto-objects])], | ||
12 | - [AC_MSG_RESULT([skipping -flto, optimization not enabled])]) | ||
13 | AC_SUBST([OUR_CFLAGS], "$with_cflags $sanitizer_cflags") | ||
14 | |||
15 | AS_CASE([$CFLAGS], [*-O[[12345\ ]]*], | ||
16 | -- | ||
17 | 2.5.0 | ||
18 | |||
diff --git a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend b/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend deleted file mode 100644 index d86ee9d..0000000 --- a/meta-nvidia-extras/recipes/systemd/systemd_%.bbappend +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_tegra-t18x := "${THISDIR}/${PN}:" | ||
diff --git a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend b/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend deleted file mode 100644 index 85a2996..0000000 --- a/meta-nvidia-extras/recipes/tegra-drivers/tegra-drivers_%.bbappend +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | GRAPHICS_PACKAGES = " \ | ||
2 | virtual/libgles2 \ | ||
3 | virtual/libegl \ | ||
4 | virtual/egl \ | ||
5 | libgbm \ | ||
6 | libgbm-dev \ | ||
7 | " | ||
8 | |||
9 | PROVIDES_append = " ${GRAPHICS_PACKAGES}" | ||
10 | RPROVIDES_append_${PN} = " ${GRAPHICS_PACKAGES}" | ||
11 | CONFLICTS_append_${PN} = " ${GRAPHICS_PACKAGES}" | ||
12 | REPLACES_append_${PN} = " ${GRAPHICS_PACKAGES}" | ||
diff --git a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend b/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend deleted file mode 100644 index db0da64..0000000 --- a/meta-nvidia-extras/recipes/wayland-nv/wayland-nv.bbappend +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | EXTRA_PROVIDES = " \ | ||
2 | virtual/wayland-native \ | ||
3 | wayland-native \ | ||
4 | " | ||
5 | |||
6 | PROVIDES_append = "${EXTRA_PROVIDES}" | ||
7 | RPROVIDES_append_${PN} = "${EXTRA_PROVIDES}" | ||
8 | CONFLICTS_append_${PN} = "${EXTRA_PROVIDES}" | ||
9 | REPLACES_append_${PN} = "${EXTRA_PROVIDES}" | ||