summaryrefslogtreecommitdiffstats
path: root/meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch')
-rw-r--r--meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch b/meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch
new file mode 100644
index 0000000..b7230cb
--- /dev/null
+++ b/meta-nvidia-extras/recipes/weston/NVIDIA-weston-configure.patch
@@ -0,0 +1,30 @@
1diff --git a/configure.ac b/configure.ac
2index 691878f..0564bb2 100644
3--- a/configure.ac
4+++ b/configure.ac
5@@ -174,10 +174,10 @@ AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor],,
6 AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor = xyes)
7 if test x$enable_drm_compositor = xyes; then
8 AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
9- PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.30 gbm mtdev >= 1.1.0])
10- PKG_CHECK_MODULES(DRM_COMPOSITOR_GBM, [gbm >= 10.2],
11- [AC_DEFINE([HAVE_GBM_FD_IMPORT], 1, [gbm supports dmabuf import])],
12- [AC_MSG_WARN([gbm does not support dmabuf import, will omit that capability])])
13+ PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm mtdev >= 1.1.0])
14+ #PKG_CHECK_MODULES(DRM_COMPOSITOR_GBM, [gbm >= 10.2],
15+ #[AC_DEFINE([HAVE_GBM_FD_IMPORT], 1, [gbm supports dmabuf import])],
16+ #[AC_MSG_WARN([gbm does not support dmabuf import, will omit that capability])])
17 fi
18
19 AC_ARG_ENABLE(eglstream-compositor, [ --enable-eglstream-compositor],,
20@@ -190,8 +190,8 @@ fi
21 PKG_CHECK_MODULES(LIBINPUT_BACKEND, [libinput >= 0.8.0])
22 PKG_CHECK_MODULES(COMPOSITOR, [$COMPOSITOR_MODULES])
23
24-PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.2],
25- [ac_wayland_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
26+#PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.2],
27+# [ac_wayland_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
28 AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, $ac_wayland_protocols_pkgdatadir)
29
30 AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,