summaryrefslogtreecommitdiffstats
path: root/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend')
-rw-r--r--meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
new file mode 100644
index 0000000..70ee515
--- /dev/null
+++ b/meta-nvidia-extras/recipes/linux/linux-nvidia.bbappend
@@ -0,0 +1,69 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30do_unpack_append() {
31 rm -rf ${STAGING_KERNEL_DIR}
32 ln -s ${S} ${STAGING_KERNEL_DIR}
33}
34
35do_kernel_defconfig_prepend () {
36}
37
38do_compile_prepend () {
39 # cross_compile_exports
40 export ARCH=${KERNEL_ARCH}
41 export CROSS_COMPILE=${CROSS_COMPILE}
42
43 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
44 echo "CONFIG_USB_ACM=m" >> ${B}/.config
45
46 make olddefconfig
47}
48
49do_install () {
50 kernel_do_install
51
52 s=$(readlink -m "${S}")
53 kernsrc="${STAGING_KERNEL_DIR}"
54
55 if [ "${s}" != "${kernsrc}" ]; then
56 mkdir -p "${kernsrc}"
57 rm -rf "${kernsrc}"
58 mv "${S}" "${STAGING_KERNEL_DIR}"
59 ln -sf "${kernsrc}" "${s}"
60 fi
61}
62
63do_deploy() {
64 kernel_do_deploy
65}
66
67do_compile () {
68 kernel_do_compile
69}