summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb')
-rw-r--r--meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb b/meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb
new file mode 100644
index 0000000..8682c27
--- /dev/null
+++ b/meta-intel-extras/recipes/microcode-initramfs/microcode-initramfs.bb
@@ -0,0 +1,52 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Initramfs with early load intel microcode"
31LICENSE = "The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
33
34inherit deploy nopackages
35
36do_compile[depends] += " \
37 ${INITRAMFS_IMAGE}:do_image_complete \
38 ${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', 'intel-microcode:do_deploy', '', d)} \
39 "
40
41do_compile() {
42 # https://www.kernel.org/doc/Documentation/x86/microcode.txt
43 microcode="${@bb.utils.contains('MACHINE_FEATURES', 'intel-ucode', '${DEPLOY_DIR_IMAGE}/microcode.cpio ', '', d)}"
44 cat ${microcode} ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz > ${S}/microcode-initramfs
45}
46
47do_deploy() {
48 install -d ${DEPLOYDIR}
49 install -m 0644 ${S}/microcode-initramfs ${DEPLOYDIR}/
50}
51
52addtask deploy before do_build after do_compile