summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch')
-rw-r--r--meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
new file mode 100644
index 0000000..d2d6755
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/disable-asm-on-non-gcc.patch
@@ -0,0 +1,29 @@
1Configure checks for compiler to be gcc and then it enables asm_offsets
2generation. see
3
4https://cgit.freedesktop.org/mesa/mesa/commit/?id=73c9b4b0e05fc66629ba250846948dc55c0e7a0d
5
6However, we missed the check when enabling this on cross compilation
7when architecture for both host and target is x86
8
9Fixes errors like
10./gen_matypes > matypes.h
11/bin/bash: ./gen_matypes: No such file or directory
12
13-Khem
14
15Upstream-Status: Submitted
16
17Index: mesa-12.0.1/configure.ac
18===================================================================
19--- mesa-12.0.1.orig/configure.ac
20+++ mesa-12.0.1/configure.ac
21@@ -732,7 +732,7 @@ test "x$enable_asm" = xno && AC_MSG_RESU
22 if test "x$enable_asm" = xyes -a "x$cross_compiling" = xyes; then
23 case "$host_cpu" in
24 i?86 | x86_64 | amd64)
25- if test "x$host_cpu" != "x$target_cpu"; then
26+ if test "x$host_cpu" != "x$target_cpu" -o "x$acv_mesa_CLANG" = xyes; then
27 enable_asm=no
28 AC_MSG_RESULT([no, cross compiling])
29 fi