summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch')
-rw-r--r--meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
new file mode 100644
index 0000000..e49695b
--- /dev/null
+++ b/meta-intel-extras/recipes/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
@@ -0,0 +1,37 @@
1From 2f68fcaaf4964e7feeb383f5c26851965cda037c Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Tue, 15 Nov 2016 15:20:49 +0200
4Subject: [PATCH] Simplify wayland-scanner lookup
5
6Don't use pkg-config to lookup the path of a binary that's in the path.
7
8Alternatively we'd have to prefix the path returned by pkg-config with
9PKG_CONFIG_SYSROOT_DIR.
10
11Upstream-Status: Pending
12Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
13---
14 configure.ac | 7 +------
15 1 file changed, 1 insertion(+), 6 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index e56e35a..a92005a 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -2020,12 +2020,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
22 AC_MSG_ERROR([cannot build egl state tracker without EGL library])
23 fi
24
25-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
26- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
27- WAYLAND_SCANNER='')
28-if test "x$WAYLAND_SCANNER" = x; then
29- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
30-fi
31+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
32
33 # Do per-EGL platform setups and checks
34 egl_platforms=`IFS=', '; echo $with_egl_platforms`
35--
362.1.4
37