summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend')
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
new file mode 100644
index 0000000..d002240
--- /dev/null
+++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
@@ -0,0 +1,40 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
23SRC_URI += "file://grub.cfg"
24
25do_deploy_prepend() {
26
27cat > ${WORKDIR}/cfg <<EOF
28search.file /boot/grub2/grub.cfg root
29set prefix=/boot/grub2
30EOF
31}
32
33do_install_append() {
34
35 install -d ${D}/boot/grub2/
36 install -m 644 ${WORKDIR}/grub.cfg ${D}/boot/grub2/
37}
38
39PACKAGES += "${PN}-config"
40FILES_${PN}-config = "/boot/grub2/"