summaryrefslogtreecommitdiffstats
path: root/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend')
-rw-r--r--meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
new file mode 100644
index 0000000..8a223fe
--- /dev/null
+++ b/meta-intel-extras/recipes/grub/grub-efi_2.00.bbappend
@@ -0,0 +1,48 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "file://grub.cfg"
32
33do_deploy_prepend() {
34
35cat > ${WORKDIR}/cfg <<EOF
36search.file /boot/grub2/grub.cfg root
37set prefix=/boot/grub2
38EOF
39}
40
41do_install_append() {
42
43 install -d ${D}/boot/grub2/
44 install -m 644 ${WORKDIR}/grub.cfg ${D}/boot/grub2/
45}
46
47PACKAGES += "${PN}-config"
48FILES_${PN}-config = "/boot/grub2/"