summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
new file mode 100644
index 0000000..cb94605
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -0,0 +1,43 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \
32 file://0001-colibri-vf-remove-console-from-tty1.patch \
33 file://0002-colibri-vf-fix-mmc-boot.patch \
34 file://0001-Update-default-args-for-apalis-imx6.patch \
35 file://0001-colibri-imx7-fix-update-u-boot.patch \
36 "
37
38do_compile_append () {
39 if [ "${MACHINE}" = "colibri-vf" ]; then
40 oe_runmake u-boot-nand.imx
41 fi
42
43}