summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
new file mode 100644
index 0000000..c5fa923
--- /dev/null
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
@@ -0,0 +1,36 @@
1From 22c5a278b98cf6ea4e4a402bca19d1354ab3c431 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Tue, 25 Sep 2018 16:05:17 +0300
4Subject: [PATCH] Disable build for tools and use mkimage from sysroot
5
6fails when trying to compile with host gcc: unable to execute
7'x86_64-linux-gnu-gcc': No such file or directory
8---
9 Makefile | 2 +-
10 scripts/Makefile.lib | 2 +-
11 2 files changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index 119ad49eec..022690e26e 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -698,7 +698,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
18
19 libs-y := $(sort $(libs-y))
20
21-u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y))) tools examples
22+u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y)))
23
24 u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-))))
25
26diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
27index 80ddb08474..e86c949f08 100644
28--- a/scripts/Makefile.lib
29+++ b/scripts/Makefile.lib
30@@ -493,5 +493,5 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
31 # ---------------------------------------------------------------------------
32 MKIMAGEOUTPUT ?= /dev/null
33 quiet_cmd_mkimage = MKIMAGE $@
34-cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
35+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
36 $(if $(KBUILD_VERBOSE:1=), >$(MKIMAGEOUTPUT))