summaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend')
-rw-r--r--meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
new file mode 100644
index 0000000..3b9fc50
--- /dev/null
+++ b/meta-fsl-extras/recipes/linux/linux-warp7_4.1.bbappend
@@ -0,0 +1,52 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SRCBRANCH = "linux_4.1.29"
31SRCREV = "881845d84e3c2e58a00b9c36616203d748b7df0e"
32LOCALVERSION = "-warp7"
33
34FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
35SRC_URI += " \
36 file://0001-Fix-dev-hwrng-by-enabling-warp7-crypto-device.patch \
37 "
38
39do_configure_prepend() {
40 echo "CONFIG_NAMESPACES=y" >> ${B}/.config
41 echo "CONFIG_FHANDLE=y" >> ${B}/.config
42 echo "CONFIG_USB_FUNCTIONFS=m" >> ${B}/.config
43
44 echo "CONFIG_MXC_CAMERA_OV2680_MIPI=m" >> ${B}/.config
45 echo "CONFIG_FB_MXC_TRULY_PANEL_TDO_ST7796H=y" >> ${B}/.config
46 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_CORE=y" >> ${B}/.config
47 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_RMI_DEV=y >> ${B}/.config
48 echo "CONFIG_TOUCHSCREEN_SYNAPTICS_DSX_FW_UPDATE=y >> ${B}/.config
49
50 echo "CONFIG_FTRACE=y" >> ${B}/.config
51 echo "CONFIG_UPROBE_EVENT=y" >> ${B}/.config
52}