diff options
Diffstat (limited to 'meta-boot2qt/recipes-qt/qt5/qtsimulator_1.0.bb')
-rw-r--r-- | meta-boot2qt/recipes-qt/qt5/qtsimulator_1.0.bb | 74 |
1 files changed, 74 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/qt5/qtsimulator_1.0.bb b/meta-boot2qt/recipes-qt/qt5/qtsimulator_1.0.bb new file mode 100644 index 0000000..c4c8d21 --- /dev/null +++ b/meta-boot2qt/recipes-qt/qt5/qtsimulator_1.0.bb | |||
@@ -0,0 +1,74 @@ | |||
1 | ############################################################################ | ||
2 | ## | ||
3 | ## Copyright (C) 2017 The Qt Company Ltd. | ||
4 | ## Contact: https://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:GPL$ | ||
9 | ## Commercial License Usage | ||
10 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
11 | ## accordance with the commercial license agreement provided with the | ||
12 | ## Software or, alternatively, in accordance with the terms contained in | ||
13 | ## a written agreement between you and The Qt Company. For licensing terms | ||
14 | ## and conditions see https://www.qt.io/terms-conditions. For further | ||
15 | ## information use the contact form at https://www.qt.io/contact-us. | ||
16 | ## | ||
17 | ## GNU General Public License Usage | ||
18 | ## Alternatively, this file may be used under the terms of the GNU | ||
19 | ## General Public License version 3 or (at your option) any later version | ||
20 | ## approved by the KDE Free Qt Foundation. The licenses are as published by | ||
21 | ## the Free Software Foundation and appearing in the file LICENSE.GPL3 | ||
22 | ## included in the packaging of this file. Please review the following | ||
23 | ## information to ensure the GNU General Public License requirements will | ||
24 | ## be met: https://www.gnu.org/licenses/gpl-3.0.html. | ||
25 | ## | ||
26 | ## $QT_END_LICENSE$ | ||
27 | ## | ||
28 | ############################################################################ | ||
29 | |||
30 | DESCRIPTION = "QtSimulator" | ||
31 | LICENSE = "The-Qt-Company-DCLA-2.1" | ||
32 | LIC_FILES_CHKSUM = "file://src/simulator/simulatorglobal.h;md5=3daa1a609195439d0292259a74c7d615;beginline=1;endline=20" | ||
33 | |||
34 | inherit qt5-module | ||
35 | |||
36 | SRC_URI = " \ | ||
37 | git://codereview.qt-project.org/tqtc-boot2qt/qtsimulator;branch=${BRANCH};protocol=ssh \ | ||
38 | file://emulatorproxyd.sh \ | ||
39 | file://emulatorproxy.service \ | ||
40 | file://emulator-hostname.sh \ | ||
41 | file://emulator \ | ||
42 | file://custom.target \ | ||
43 | " | ||
44 | |||
45 | SRCREV = "f98633ebee7dbce79c00fbfec86537c6330e2b5f" | ||
46 | BRANCH = "master" | ||
47 | |||
48 | S = "${WORKDIR}/git" | ||
49 | |||
50 | DEPENDS = "qtbase" | ||
51 | RRECOMMENDS_${PN} += "${PN}-tools" | ||
52 | |||
53 | # Proxy daemon for QtSimulator | ||
54 | do_install_append() { | ||
55 | install -m 0755 -d ${D}${sysconfdir}/init.d | ||
56 | install -m 0755 ${WORKDIR}/emulatorproxyd.sh ${D}${sysconfdir}/init.d/ | ||
57 | |||
58 | install -m 0755 -d ${D}${systemd_unitdir}/system | ||
59 | install -m 0644 ${WORKDIR}/emulatorproxy.service ${D}${systemd_unitdir}/system/ | ||
60 | install -m 0644 ${WORKDIR}/custom.target ${D}${systemd_unitdir}/system/ | ||
61 | |||
62 | install -m 0755 -d ${D}${sysconfdir}/profile.d | ||
63 | install -m 0644 ${WORKDIR}/emulator-hostname.sh ${D}${sysconfdir}/profile.d/ | ||
64 | |||
65 | install -m 0755 -d ${D}${sysconfdir}/default | ||
66 | install -m 0644 ${WORKDIR}/emulator ${D}${sysconfdir}/default/ | ||
67 | } | ||
68 | |||
69 | INITSCRIPT_NAME = "emulatorproxyd.sh" | ||
70 | INITSCRIPT_PARAMS = "defaults 97 10" | ||
71 | |||
72 | SYSTEMD_SERVICE_${PN} = "emulatorproxy.service custom.target" | ||
73 | |||
74 | inherit update-rc.d systemd | ||