summaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb
new file mode 100644
index 0000000..e77d7b2
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb
@@ -0,0 +1,64 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Boot to Qt Demo Launcher"
31LICENSE = "(BSD & GPL-3.0) | The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
33
34inherit qmake5
35require recipes-qt/qt5/qt5-git.inc
36
37QT_GIT_PROJECT = "qt-apps"
38
39SRC_URI += " \
40 file://b2qt-startup.sh \
41 file://qtlauncher.service \
42 file://b2qt.service \
43 "
44
45SRCREV = "8d7fe0e4b8852a16469a6d0fe910309e8964ab58"
46
47DEPENDS = "qtbase qtdeclarative \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)}"
49
50do_install_append() {
51 install -m 0755 -d ${D}${sysconfdir}/init.d
52 install -m 0755 ${WORKDIR}/b2qt-startup.sh ${D}${sysconfdir}/init.d/
53
54 install -m 0755 -d ${D}${systemd_unitdir}/system
55 install -m 0644 ${WORKDIR}/qtlauncher.service ${D}${systemd_unitdir}/system/
56 install -m 0644 ${WORKDIR}/b2qt.service ${D}${systemd_unitdir}/system/
57}
58
59INITSCRIPT_NAME = "b2qt-startup.sh"
60INITSCRIPT_PARAMS = "defaults 30"
61
62SYSTEMD_SERVICE_${PN} = "qtlauncher.service b2qt.service"
63
64inherit update-rc.d systemd